Every time I CPT i/R for TVM, it shows RST 0.00


When solving for a TVM question, (PV= -882.68 , FV=1000, PMT=100, N=4, CPT I/R) on my Texas BA II Plus, whenever I CPT i/r in one of my BA2 plus, it automatically switches to RST 0.00 (resetting all settings to defaults). However, when I tried the exact same process on my other exact same Texas BA II Plus model, it gives the correct answer, which is perplexing.

I tried clearing TVM and reinstalling the battery to no avail. Has anyone come across this with a solution? Any help is appreciated

I have encountered the same problem and researched across the Internet. Eventually it turned out to be just a result of low battery. Mine was fine right after replacing the existing battery with a brand new one.

However for your case there’s chance that the internal circuit board has already been damaged. I strongly encourage you to buy a new calculator. Small cost for greater good.

Hi Encore2019,

Thanks for your response, much appreciated. I could not find any other solution after months, including Texas support, so ended up getting a new calculator. I actually did not change the battery in this one, but now that I sold it (informing the new owner of the flaw), I wont get the chance to try that out. But you are right, small cost for great good.

Thanks again for your input