Schweser Online Videos not working


I finally pulled the trigger and bought the online Schweser videos. I downloaded the IPad conference app required and navigated to the class I wanted to view a video for (the Future/Forward videos, equitizing cash, video). After clicking on the link, the video seems to try to load (huff and puffs with a wait cursor), but the video never starts. I can see the scroll cursor and video window appear but no content ever starts. The only sign of hope I could see is that if I move the cursor forward, a lecture slide appears on the screen.

Anybody else have this problem? And anybody in AsiaPacific have this, I’m thinking it might be a bandwidth problem or something.

Umm, you tried some other browser?

It doesnt work on ipad. I initially thought it didnt work due to my slow connection in jakarta, but i bought a sony laptop, and it works ok now. I have two ipads (ipad 1 and mini) it didnt work in either. It worked ok on my surface or my vaio

Strange. I tried on both my Samsung tablets, my Samsung watch, my Google glasses and all of my smart phones. Did work just fine. cool

they work fine on my ipad here in the UK, even on ropey hotel and departure lounge connections.

Have you contacted Schweser to complain? It seems pretty shoddy that they would sell a product that doesn’t work on tablets in certain parts of the world.

Doesn’t work on IOS

Works on my ipad here in the US. I remember it didn’t work last year for me in L2 though…only thing I can think of thats changed between then and now has been OS updates. Good luck

I got it to work finally and on IPad. PC still doesn’t work.

I had to download a different browser called Puffin.